Black Staff bug- SS

Bugs with Arelith (in-game and out) should be reported here.

Moderators: Active DMs, Forum Moderators, Contributors

Post Reply
carnage65
Posts: 2
Joined: Thu Jan 17, 2019 11:20 pm

Black Staff bug- SS

Post by carnage65 » Thu Jan 09, 2020 7:14 am

Description
==========
Blackstaff when casted will consume 1 imbuement from the ss weapon both before or after the imbue's are put on a weapon. To specify, if the weapon already has the double imbues on it blackstaff when cast on the pc will remove the first imbue cast. If blackstaff is cast before the imbues the first imbue will not stick and simply disappear.


Steps to reproduce
----------------------------
I have had this bug consistently throughout leveling since I started the use of blackstaff some time ago. I have used this spell no less than 100 times with the same result.


Expected result
-----------------------
blackstaff will not consume casted imbue when used.

Actual result
-------------------
blackstaff takes one imbue off of the weapon or consumes the first imbue cast after the blackstaff spell has been expended

Screenshot(s)
--------------------
No screenshots currently though if necessary I can provide.

Notes
---------
I have tried a myriad of possibilities thinking that perhaps server transitions may play a roll, however, no matter in what order under what circumstance have I found a work around on this issue other than keeping a 3rd imbue handy.

msheeler
Contributor
Contributor
Posts: 79
Joined: Mon Dec 31, 2018 10:32 pm

Re: Black Staff bug- SS

Post by msheeler » Mon Jan 13, 2020 6:19 pm

Have you tried to un-equip the weapon then cast it targeting the weapon in your inventory?

msheeler
Contributor
Contributor
Posts: 79
Joined: Mon Dec 31, 2018 10:32 pm

Re: Black Staff bug- SS

Post by msheeler » Mon Jan 13, 2020 6:20 pm

That process works for other things like Bless Weapon and Holy Sword too.

Wrips
Posts: 137
Joined: Sun Apr 29, 2018 5:06 am

Re: Black Staff bug- SS

Post by Wrips » Mon Jan 13, 2020 6:23 pm

The way to make Blackstaff work correctly is to imbue your weapons first and then you cast Blackstaff on your character, not the weapon.

carnage65
Posts: 2
Joined: Thu Jan 17, 2019 11:20 pm

Re: Black Staff bug- SS

Post by carnage65 » Tue Jan 14, 2020 9:46 pm

msheeler wrote:
Mon Jan 13, 2020 6:19 pm
Have you tried to un-equip the weapon then cast it targeting the weapon in your inventory?
I have not but will test it now.
Wrips wrote:
Mon Jan 13, 2020 6:23 pm
The way to make Blackstaff work correctly is to imbue your weapons first and then you cast Blackstaff on your character, not the weapon.
As I've stated in my post casting blackstaff after i've imbued my weapon removes the first imbue cast.

Wrips
Posts: 137
Joined: Sun Apr 29, 2018 5:06 am

Re: Black Staff bug- SS

Post by Wrips » Tue Jan 14, 2020 11:50 pm

carnage65 wrote:
Tue Jan 14, 2020 9:46 pm
As I've stated in my post casting blackstaff after i've imbued my weapon removes the first imbue cast.
The only instance that this happens to my character is when I cast Blackstaff directly on the weapon, like the imbues. If I cast Blackstaff on the character, like zoo spells for example, it works as intended.

StoneBreaker
Posts: 36
Joined: Tue Jun 27, 2017 4:54 am

Re: Black Staff bug- SS

Post by StoneBreaker » Mon Feb 10, 2020 2:29 am

I cant seem to get blackstaff to work at all. it casts but no error messages and my weapon doesnt have any buff for blackstaff

Post Reply